Saturday, May 10, 2025

Portfolio and Experience

PORTFOLIO:

2010 : Author of  IT Book ( Hardware CPU X86) in GPINKOM Community as student
2011 : Instructor Hardware X86 at Dian Institute

2012 -  until today : Freelance network engineer ( Mikrotik since ROS5, Cisco, Juniper, NGFW) For Small Office,  Enterprise and Goverment.
** need service email to  fiance.ticoalu@yahoo.com | subject : "need network setting services"


2016 : making smart toilete with atmega (final course project)

2024 : Making IoT System ( Truck weighing system integration with ESP8266 Send to MySQL)
2024 : Making Web System for UI weighing system integration)
2025 : Online IT Instructor 


EXPERIENCE

2010 : Team PSB Online and Siap Online Pasuruan -  under telkom/nipcom
2012 - 2020 : IT Support onsite at PT. Terminal Petikemas surabaya as vendor
2020-2021 :  IT Support onsite at PT. Bank Danamon Indonesia as vendor
2021 - until today : IT Staff  at PT. Timur Jaya Indosteel


Thursday, May 30, 2024

Static Routing Advanced Explained by Fiance Ticoalu (Mikrotik)


As we understand it... routing is about finding the best path.

static routing is relative simple..where is the connected network and where is the remote network, next  set up  dst-address and gateway in the routers... if working ...finish. But it's not that simple.

 

1. Routing Component:

- RIB ( Routing Information Base ) / Routing Table

- FIB ( Forwarding Information Base ) / Forwarding Table








- RIB (Routing Table) contains route data to a specific network.
- RIB (Routing Table) contains metric(value/priority) from each route.
- RIB (Routing Table) made from :
  - All route from dynamic routing protocol
  - All route from connected network
  - All route from static route.

Example: Mikrotik Routing Table in Winbox



2. Administrative Distance:

-Used for finding the best path, when there is more than one routing protocol to same spesific destination.

-Value distance is 0 - 255 | distance = 255 is  rejected.

- The Smallest distance is prioritized.










Monday, May 27, 2024

Load Balancing explained by Fiance Ticoalu (MikroTik)

 

The purpose of load balancing, at it simplest : minimizing overload traffic in a path/link.

 List of load balancing type/algorithm :

1. Per packet load balancing

2. Per connection load balancing

3. Per address-pair load balancing

4. Custom load balancing



1. PER PACKET LOAD BALANCING.

 The packets from one session will be split and forward to multiple path.

Example: packets from one session from ip address 192.168.1.1/24 to www.youtube.com  will be split and forward by router to internet ISP1(universal) 101.0.100.254/30 - ISP2 (biznet) 210.0.210.254/30)
because packet is forwarding by router to different ISP, delays between one and other packet is happened. No matter how fast your Internet connection will slow down.

 

2. PER CONNECTION LOAD BALANCING.

The packets from one session,  forward to one path/link only  (the packets not splited)

Example: packets from one session (first session) from ip address 192.168.1.1/24 to www.youtube.com, forwarded to one path only by router (ISP1 universal)

Example: packets from one session (second session) from ip address 192.168.1.1/24 to www.youtube.com, forwarded to one path only by router (ISP2  biznet)

 

2. PER ADDRESS PAIR LOAD BALANCING.

 

 

 

 




Sunday, July 10, 2022

VIRTUAL LOCAL AREA NETWORK - VLAN (MikroTik)

 

    Picture 1


- VLAN is VPN (Without authentication and without encryption)

- VLAN almost universally adopted beetwen different vendor

 

1. VLAN Terms (Look at  Picture 1) 

Tagged VLAN = All Packet forwarded by the interface contain VLAN information/ VLAN-ID

Untagged VLAN = Packet Forwarded by the interface are untagged 

Trunk Port = Carry Multiple VLANs ID on single physical interface

Access Port = Belong to one Vlan ID, Port is untagged

**Hybird Port = Multiples VLANs can be tagged and untagged


2. VLAN in Router OS/ MikroTik.

Today is possible to manage VLAN in 3 different menus

1. Interface
2. Bridge
3. Switch


and what is different beetwen them, when we use it ?

 The Software VLAN:

When we use Interface to create and manage VLAN in the Mikrotik, Traffic will affect  and will affected by the CPU

 The Hardware VLAN:

When we use Switch to create and manage VLAN in the Mikrotik Traffic will not affect the CPU.
but the following ones is possibly when router board have a switch chip or we use Cloud Router Switch - Switch Layer 3 Mikrotik. 

The VLANs in the Bridge:

When Managed VLAN in the Bridge, Traffic will be can software or hardware VLAN, Depending of the switch chip location in interface and how is configured!


3. Let's Config

Look at picture 1 :

- (red line vlan 10 ether2 / blue line vlan20 ether3)  on switch layer3

- trunk port ether1 on switch layer3

- ether2 in router connected to switch layer3 port  ether1 (trunk) 

We Config using  the VLANs in the bridge (use RB with switch chip or CRS it's okay and working)

Config in Router

/interface vlan
add name=vlan10 interface=ether2 vlan-id=10
add name=vlan20 interface=ether2 vlan-id=20

/ip address
add address=192.168.10.254/24 interface=vlan10
add address=192.168.20.254/24 interface=vlan20


Config in Switch Layer 3

/interface bridge
add name=bridge1 vlan-filtering=no 

(don't forget to disable vlan filtering/no. in last config we make vlan filtering is on) / when in first config we enable vlan fitlering, switch layer 3 cannot access

/interface bridge port
add bridge=bridge1 interface=ether1 pvid=1 ingress filtering=yes

/interface bridge port
add bridge=bridge1 interface=ether2 pvid=10

/interface bridge port
add bridge=bridge1 interface=ether3 pvid=20

and then, we setting tagged/untagged vlan

 /interface bridge vlan
add bridge=bridge1 tagged=ether1 untagged=ether2 vlan-ids=10

/interface bridge vlan
add bridge=bridge1 tagged=ether1 untagged=ether3 vlan-ids=20
 

last config we enable vlan filtering in bridge interface from no to yes 

/interface bridge set bridge1 vlan-filtering=yes 

set up ip address on end device / create dhcp server in vlan10 or vlan20 interface

finish.